Vous n'êtes pas identifié(e).

Top posteurs

Statistiques

Partenaires

  • eXolia Hosting
  • Eggdrop.fr

#1 12/11/2011 05:39:44

Damien
Méchant Modérateur.
Lieu : Bruxelles
Inscription : 20/06/2011
Messages : 237
Site Web

[NeoStats] Configure - Aucune détection de perl.

Hello,

J'était occuper à réinstaller NeoStats sur mon serveur local quand, à la fin du "configure" j'ai eu droit à

* I get a link error: /usr/bin/ld: cannot find -lperl during the make step
of the installation on Debian. What's wrong?

- You need to install the libperl-dev package.

Alternatively, create a symbolic link from libperl.so.5.6.1 to libperl.so in
/usr/lib:

    % cd /usr/lib; ln -s libperl.so.5.6.1 libperl.so
and re-run the make step of the installation.

or if you dont want to take advantage of perl modules and extensions, then
you can run ./configure --disable-perl

Hors, libperl (libperl5.10.1) et libperl-dev sont biens présents.

Le fichier "libperl.so" est également bien présent... J'ai déjà tenter de réinstaller correctement les libs, mais rien à faire.

Si quelqu'un aurait une petite idée sur le problème, ça ne serait pas de refus.

Cordialement,

Ps: pour info le serveur tourne sous debian squeeze (64bits).

Dernière modification par Damien (12/11/2011 05:41:32)


En informatique il n'y a pas de mauvais outils, il n'y a que de mauvais utilisateurs. Le problème le plus récurrent est celui qui se trouve entre la chaise et le clavier.

Hors ligne

#2 12/11/2011 09:32:04

Harakiri
Administrateur
Lieu : Paris
Inscription : 02/07/2011
Messages : 260

Re : [NeoStats] Configure - Aucune détection de perl.

Salut,

NeoStats semble avoir besoin de la version 5.6.1 d'après les messages d'erreur, et tu indiques que la version installée sur ta machine est la 5.10.1.
As-tu essayé de faire le lien symbolique comme il est indiqué dans le debug ?


EOF

Hors ligne

#3 12/11/2011 18:19:33

Damien
Méchant Modérateur.
Lieu : Bruxelles
Inscription : 20/06/2011
Messages : 237
Site Web

Re : [NeoStats] Configure - Aucune détection de perl.

Salut Harakiri,

Faire un lien symbolique me retourne une erreur me disant que "libperl.so" existe déjà.

Même, si je renomme le fichier "libperl.so" et recrée un lien symbolique comme indiqué dans l'erreur... C'est pareille.

Cordialement,


En informatique il n'y a pas de mauvais outils, il n'y a que de mauvais utilisateurs. Le problème le plus récurrent est celui qui se trouve entre la chaise et le clavier.

Hors ligne

#4 12/11/2011 19:34:19

Harakiri
Administrateur
Lieu : Paris
Inscription : 02/07/2011
Messages : 260

Re : [NeoStats] Configure - Aucune détection de perl.

Si ça te met qu'il existe déjà, c'est parce que tu dois te tromper dans l'ordre des arguments.

ln [OPTION]... [-T] TARGET LINK_NAME

Le paramètre 'target' étant le fichier vers lequel le lien mènera, il semble que les indications fournies sont inéxactes !

Edit : J'avais mal compris le problème, on va oublier ce que j'ai dit big_smile


EOF

Hors ligne

#5 12/11/2011 22:49:27

Damien
Méchant Modérateur.
Lieu : Bruxelles
Inscription : 20/06/2011
Messages : 237
Site Web

Re : [NeoStats] Configure - Aucune détection de perl.

Hum,

Non, car le fichier "libperl.so" existe déjà vu qu'il pointe vers libperl.so.5.10.1.


En informatique il n'y a pas de mauvais outils, il n'y a que de mauvais utilisateurs. Le problème le plus récurrent est celui qui se trouve entre la chaise et le clavier.

Hors ligne

Pied de page des forums

475439 visites ( 266 aujourd'hui ) 7 visiteurs en ligne
Copyright © 2004 - 2013 IRCz