Vous n'êtes pas identifié(e).

Top posteurs

Statistiques

Partenaires

  • eXolia Hosting
  • Eggdrop.fr

#1 31/03/2012 12:31:11

Heyo
Nouveau IRCzien
Inscription : 31/03/2012
Messages : 3

[Résolu] [Anope 1.9] Problème MySQL

Bonjour,
Je tente d'utiliser MySQL avec Anope 1.9.6.

J'ai donc décommenté la ligne "module { name = "db_sql" }" en définissant "engine" par "mysql/main", la ligne "module { name = "db_sql_live_read" }" et la ligne" module { name = "db_sql_live_write" }" dans le fichier services.conf.

J'ai aussi décommenté les lignes "module { name = "m_mysql" }" tout en remplissant les champs nécessaires dans le fichier "modules.conf" que j'ai ensuite inclus dans le fichier "services.conf".

Pourtant, lorsque je tente d'enregistrer un pseudo, je reçois la notice suivante :

"*** Global -- from OperServ: Unable to locate SQL reference, going to readonly..."

Qu'ai-je oublié de faire/mal fait ?

Merci d'avance,
Heyo.

Hors ligne

#2 01/04/2012 18:54:48

Harakiri
Administrateur
Lieu : Paris
Inscription : 02/07/2011
Messages : 260

Re : [Résolu] [Anope 1.9] Problème MySQL

Salut,

Je pense que ton erreur vient de la configuration de la partie mysql, à savoir :

Code:
/*                                                                                                                                             
 * m_mysql                                                                                                                                     
 *                                                                                                                                             
 * This module allows other modules to use MySQL.                                                                                              
 */
module { name = "m_mysql" }
mysql
{
        /* The name of this service */
        name = "mysql/main"
        database = "anope"
        server = "localhost"
        username = "anope"
        password = "pass"
        port = 3306
}

Ma configuration fonctionne, j'avais le même problème que toi lorsqu'à la place de 'localhost', il y avait '127.0.0.1'. Assez étrange, mais après mes quelques petits tests, c'est bien la source du problème (me concernant).
Si ce n'est pas ça, alors fournis-nous les logs qui sont générés lors du démarrage de tes services s'il te plait, pour mieux comprendre ce qui ne va pas.

smile


EOF

Hors ligne

#3 02/04/2012 19:48:24

Heyo
Nouveau IRCzien
Inscription : 31/03/2012
Messages : 3

Re : [Résolu] [Anope 1.9] Problème MySQL

Hélas, ça ne change rien, j'avais déjà essayé. hmm
Les logs ne m'en apprennent pas plus :

Code:
[Apr 02 17:21:10 2012] SERVER: Anope.xxxxxxx.org (Anope - xxxxxxx.org) uplinked to no uplink connected to the network
[Apr 02 17:21:10 2012] Anope 1.9.6 (1) starting up
[Apr 02 17:21:10 2012] Can not load languages, gettext is not installed
[Apr 02 17:21:10 2012] Loading modules...
[Apr 02 17:21:10 2012] Error while loading ns_cert: Your IRCd does not support ssl client certificates
[Apr 02 17:21:10 2012] Error while loading ns_resetpass: Not using mail.
[Apr 02 17:21:10 2012] Error while loading ns_sendpass: Not using mail.
[Apr 02 17:21:11 2012] Error while loading m_proxyscan: m_proxyscan:target_ip may not be empty
[Apr 02 17:21:11 2012] m_ssl: No certificate file found
[Apr 02 17:21:11 2012] m_ssl: No private key found
[Apr 02 17:21:11 2012] Using IRCd protocol unreal
[Apr 02 17:21:11 2012] Loading databases...
[Apr 02 17:21:11 2012] Databases loaded
[Apr 02 17:21:11 2012] Attempting to connect to irc.xxxxxxx.org (xxx.xx.x.xxx), port 7070
[Apr 02 17:21:12 2012] Successfully connected to irc.xxxxxxx.org:7070
[Apr 02 17:21:12 2012] ModeManager: Added generic support for channel mode Z
[Apr 02 17:21:12 2012] SERVER: xxx.xxxxxxx.org (Xxx - xxxxxxx.org) uplinked to Anope.xxxxxxx.org connected to the network
[Apr 02 17:21:12 2012] SERVER: Anope.xxxxxxx.org (Anope - xxxxxxx.org) introduced xxx.xxxxxxx.org
[Apr 02 17:21:12 2012] BotServ is now an IRC operator
[Apr 02 17:21:12 2012] ChanServ is now an IRC operator
[Apr 02 17:21:12 2012] Global is now an IRC operator
[Apr 02 17:21:12 2012] HostServ is now an IRC operator
[Apr 02 17:21:12 2012] MemoServ is now an IRC operator
[Apr 02 17:21:12 2012] NickServ is now an IRC operator
[Apr 02 17:21:12 2012] OperServ is now an IRC operator
[Apr 02 17:21:12 2012] Heyo is now an IRC operator
[Apr 02 17:21:12 2012] USERS: Heyo!Heyo@xxx.xxx.xxx.xx.rev.sfr.net (xxxxxxx.org-31609A4F.rev.sfr.net) (Heyo) [xx.xxx.xxx.xxx] connected to the network (xxx.xxxxxxx.org)
[Apr 02 17:21:12 2012] SERVER: xxx.xxxxxxx.org (Xxx - xxxxxxx.org) is done syncing
[Apr 02 17:21:12 2012] SERVER: Xxxxx.xxxxxxx.org (Xxxxx - xxxxxxx.org) is done syncing
[Apr 02 17:21:12 2012] Successfully linked, launching into background...
[Apr 02 17:32:48 2012] Tied oper Heyo to type Services Root
[Apr 02 17:32:48 2012] COMMAND: Heyo@xxx.xxx.xxx.xx.rev.sfr.net used register to register Heyo (email: xxxxxxx@gmail.com)

Je pense que je vais revenir au bon vieil Anope 1.8, tant pis pour la fonction de lecture de MySQL. ^^"

Dernière modification par Heyo (02/04/2012 19:49:20)

Hors ligne

#4 02/04/2012 20:22:16

Harakiri
Administrateur
Lieu : Paris
Inscription : 02/07/2011
Messages : 260

Re : [Résolu] [Anope 1.9] Problème MySQL

Est-ce que tu as commenté les autres méthodes de stockage ?
A priori, lorsque MySQL est utilisé et reconnu par le service, un message est glissé dans les logs, lorsque la connexion est établie :

MySQL: Successfully connected to server mysql/main (localhost)

ou bien un message d'échec du genre :

MySQL: Unable to connect to SQL service mysql/main: [...]

Ca veut peut être dire que lorsqu'il trouve un moyen de stockage pour la première fois dans les modules, il ne prend pas en compte les autres.
Encore une fois rien de bien certain... Mais c'est un peu louche, et sans message d'erreur directement lié à MySQL, ça ne peut être qu'une erreur de configuration plus générale.


EOF

Hors ligne

#5 02/04/2012 21:19:34

OxMoZ
Modérateur
Inscription : 23/08/2011
Messages : 45

Re : [Résolu] [Anope 1.9] Problème MySQL

cd ~/services/
./mydbgen

Hors ligne

#6 02/04/2012 22:49:39

Harakiri
Administrateur
Lieu : Paris
Inscription : 02/07/2011
Messages : 260

Re : [Résolu] [Anope 1.9] Problème MySQL

OxMoZ a écrit :
cd ~/services/
./mydbgen

No such file or directory big_smile

Pas ça dans la version en dev, en tout cas pas chez moi !


EOF

Hors ligne

#7 03/04/2012 19:36:06

Heyo
Nouveau IRCzien
Inscription : 31/03/2012
Messages : 3

Re : [Résolu] [Anope 1.9] Problème MySQL

OxMoZ a écrit :
cd ~/services/
./mydbgen

Je ne vois pas trop ce que cela vient faire ici.

Harakiri a écrit :

Est-ce que tu as commenté les autres méthodes de stockage ?
A priori, lorsque MySQL est utilisé et reconnu par le service, un message est glissé dans les logs, lorsque la connexion est établie :

MySQL: Successfully connected to server mysql/main (localhost)

ou bien un message d'échec du genre :

MySQL: Unable to connect to SQL service mysql/main: [...]

Ca veut peut être dire que lorsqu'il trouve un moyen de stockage pour la première fois dans les modules, il ne prend pas en compte les autres.
Encore une fois rien de bien certain... Mais c'est un peu louche, et sans message d'erreur directement lié à MySQL, ça ne peut être qu'une erreur de configuration plus générale.

J'ai décommenté "module { name = "db_flatfile" }" et cela fonctionne !
J'ai pensé qu'on pouvait utiliser les deux, comme avec l'ancien Anope.

Merci. smile

Hors ligne

Pied de page des forums

501924 visites ( 140 aujourd'hui ) 9 visiteurs en ligne
Copyright © 2004 - 2013 IRCz