Vous n'êtes pas identifié(e).

Top posteurs

Statistiques

Partenaires

  • eXolia Hosting
  • Eggdrop.fr

#1 14/01/2014 15:53:13

SparTan
Nouveau IRCzien
Inscription : 14/01/2014
Messages : 2

[Résolu] Problème SSL

Bonjour.

Après avoir compiler mon serveur Unrealircd 3.2.10.2 avec support ssl paramétrer un port ssl le 6669
Rajouter les lignes de configuration suivante :

ssl {
        certificate "server.cert.pem";
        key "server.key.pem";
    };

server.cert.pem et server.key.pem etant les fichiers générés a l'installation.

J'avais en Snotice cette erreur :

Exiting ssl client [@0:0:0:0:0:ffff:*.63011]: SSL_accept(): Internal OpenSSL error or protocol error

J'ai chercher dans la FAQ de unreal mais ca ne m'en apprends pas plus. Et d'après ce que je comprends c'est une erreur de protocol.
J'ai donc essayé en générant directement des clés avec Openssl en faisant openssl genrsa -out server.key 2048 /openssl req -new -key server.key -out server.csr etc.
J'ai donc mit les clés dans la conf a la place des anciennes et j'ai toujours la même erreur.

Exiting ssl client [@0:0:0:0:0:ffff:*.63011]: SSL_accept(): Internal OpenSSL error or protocol error

Bref ne trouvant pas plus de réponses dans la FAQ de unreal et dans le forum j'ouvre ce post.
Si vous avez un tutos ou une solution je suis preneur.

Cordialement.

Hors ligne

#2 14/01/2014 15:56:39

Damien
Méchant Modérateur.
Lieu : Bruxelles
Inscription : 20/06/2011
Messages : 237
Site Web

Re : [Résolu] Problème SSL

Salut,

Il faudrait peut-être demander à ton client IRC d'utiliser SSL pour te connecter et ça marchera mieux? Si le client IRC essaie un port SSL sans le supporté (ssl), ça ne marche pas.

Cordialement,


En informatique il n'y a pas de mauvais outils, il n'y a que de mauvais utilisateurs. Le problème le plus récurrent est celui qui se trouve entre la chaise et le clavier.

Hors ligne

#3 14/01/2014 16:00:35

SparTan
Nouveau IRCzien
Inscription : 14/01/2014
Messages : 2

Re : [Résolu] Problème SSL

En effet.

Le problème était plus simple que je ne le pensait. Je croyais a une erreur de compilation ou autre mais finalement non.
J'ai paramétré mon script pour qu'il supporte ssl et ca marche tout de suite mieux.

Désolé du dérangement j'y avais pas pensé je ferait plus attention la prochaine fois.

Merci Damien.

Hors ligne

Pied de page des forums

413565 visites ( 245 aujourd'hui ) 6 visiteurs en ligne
Copyright © 2004 - 2013 IRCz