Vous n'êtes pas identifié(e).

Top posteurs

Statistiques

Partenaires

  • eXolia Hosting
  • Eggdrop.fr

#1 16/06/2014 18:44:45

Michel Henri
Nouveau IRCzien
Inscription : 21/05/2014
Messages : 8

Problème langue française Anope 2.0.1 - CentOS 6.5

Je me présente Michel Henri et j'ai un soucis avec anope le language français n'est ni détecte ni actif, aucune erreur n'est inscrite dans les logs :

Côté serveur, le language locale et bien fr_FR
la lib gettext-devel est bien installé
les configurations anope sont bien clair.

Je ne connais pas le problème

Hors ligne

#2 16/06/2014 18:59:40

Damien
Méchant Modérateur.
Lieu : Bruxelles
Inscription : 20/06/2011
Messages : 237
Site Web

Re : Problème langue française Anope 2.0.1 - CentOS 6.5

Salut,

Quel est ton système d'exploitation pour commencer?

Es-tu sur que les langues sont bien présentes ?

Normalement, tu dois avoir locales-all d'installer aussi... Sinon, ça marche pas.

Cordialement,


En informatique il n'y a pas de mauvais outils, il n'y a que de mauvais utilisateurs. Le problème le plus récurrent est celui qui se trouve entre la chaise et le clavier.

Hors ligne

#3 16/06/2014 19:20:41

Michel Henri
Nouveau IRCzien
Inscription : 21/05/2014
Messages : 8

Re : Problème langue française Anope 2.0.1 - CentOS 6.5

Mon OS : Centos 6.5

Oui le language fr_Fr est bien supporté par le server sinon il ne retournerait pas de phrase en langue française.

Mais par contres locales-all je ne connaissais pas
Je teste cela et je reviens vers vous

Par contre je ne sais pas où trouver locales-all est-ce une lib ?

Merci pour votre aide

Dernière modification par Michel Henri (16/06/2014 19:22:17)

Hors ligne

#4 16/06/2014 19:22:22

Damien
Méchant Modérateur.
Lieu : Bruxelles
Inscription : 20/06/2011
Messages : 237
Site Web

Re : Problème langue française Anope 2.0.1 - CentOS 6.5

Oui le language fr_Fr est bien supporté par le server sinon il ne retournerait pas de phrase en langue française.

Je parlais d'anope pas de la machine l'hébergeant... smile


En informatique il n'y a pas de mauvais outils, il n'y a que de mauvais utilisateurs. Le problème le plus récurrent est celui qui se trouve entre la chaise et le clavier.

Hors ligne

#5 16/06/2014 19:29:01

Michel Henri
Nouveau IRCzien
Inscription : 21/05/2014
Messages : 8

Re : Problème langue française Anope 2.0.1 - CentOS 6.5

Ok et bien les anopes ne supportent pas le language français, j'ai déjà fais les tests par les commandes nickserv

Hors ligne

#6 16/06/2014 22:45:03

Harakiri
Administrateur
Lieu : Paris
Inscription : 02/07/2011
Messages : 260

Re : Problème langue française Anope 2.0.1 - CentOS 6.5

Ayant participé à la traduction, je peux t'assurer que ça fonctionne. C'est actif chez moi.
(Oui, je parle bien de la 2.0.)

Les indications dans le fichier de doc 'LANGUAGE' ne mentionnent pas CentOS, mais globalement, il te faux gettext et/ou gettext-devel et un environnement avec des locales en français.

Tu peux passer nous voir sur IRC si tu n'arrives pas à avancer, on peut voir ça ensemble.


EOF

Hors ligne

#7 17/06/2014 12:07:22

bouba89
Nouveau IRCzien
Inscription : 31/07/2011
Messages : 48

Re : Problème langue française Anope 2.0.1 - CentOS 6.5

bonjour a tous

Michel-Henri j'ai rechercher de mon coté

et sur CentOs pour passez en language FR :


Solution 1:


yum install system-config-language
system-config-language


Solution 2:



# cd /etc/sysconfig
# cp i18n i18n.backup
# nano i18n
Change to en_US to fr_FR
ctrl+x Y and reboot


verifie par la suite avec /msg Nickserv help set language si le français t'est proposé


Cordialement

Hors ligne

#8 17/06/2014 18:15:12

Michel Henri
Nouveau IRCzien
Inscription : 21/05/2014
Messages : 8

Re : Problème langue française Anope 2.0.1 - CentOS 6.5

Non tout est déjà fait pour cela d'origine mais j'ai installé les packages que tu m'as dit c'est quand même utile

Merci beaucoup bouba, mais je ne pense pas que cela viens de centOs

Hors ligne

Pied de page des forums

474993 visites ( 141 aujourd'hui ) 9 visiteurs en ligne
Copyright © 2004 - 2013 IRCz