Vous n'êtes pas identifié(e).

Top posteurs

Statistiques

Partenaires

  • eXolia Hosting
  • Eggdrop.fr

#26 06/10/2012 16:13:39

Artefact
IRCzien
Lieu : Paris
Inscription : 06/09/2011
Messages : 140

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

mumh, tar moi ton archive "tar cf archive.tar archive" et envois la à artefact@tchatche-land.fr

Je vais tenter de le faire via mon shell !

Hors ligne

#27 06/10/2012 18:04:25

Harakiri
Administrateur
Lieu : Paris
Inscription : 02/07/2011
Messages : 260

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

mat7 a écrit :

Le groupe se crée bien lors de la question ?

Non, le groupe doit être existant. Ajouter un groupe nécessite les droits root, puisqu'il modifie le fichier /etc/group
Recommence en donnant le groupe auquel tu appartiens, si tu ne le connais pas :

id -g -n mat7

EOF

Hors ligne

#28 06/10/2012 19:07:40

mat7
Nouveau IRCzien
Lieu : Angers
Inscription : 11/11/2011
Messages : 14

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

ok ça s'explique. c'est bon il s'installe correctement smile

Merci.

Hors ligne

#29 09/10/2012 02:03:33

Ste
Nouveau IRCzien
Lieu : Germany
Inscription : 09/10/2012
Messages : 15
Site Web

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

Logiquement:

owner: <login>
usergroup: users ou login

Ensuite pour revenir au sujet initial, oui il est mieu d'installer un ircu2 de version .10.10 grand maximum pour possedé un CS6.0 (IriX)
Il est aussi utile de savoir "coder/programmer" le p10N2k ainsi que le C pour toute modification du CS/ircu2
Je suis moi même sous un ircu2.10.09 modifier [crypt MD5 host + Nickserv + NICKME]
Je tiens juste a faire un petit rappel, ircu n'est pas pour les débutant de plus il faut avoir une grande patience pour la modification de source
Celà fais quelques semaine que mon serveur est actif (lancé mais pas encore ouvert au public) et il est vrai que je retrouve les joies de
programmer le C ainsi que le TCL pour tout ce qui est Service pour mon portail.php !

Cordialement,
Ste

Dernière modification par Ste (09/10/2012 02:04:13)


¤ Ste ¤
IRC Admin :: Olympe
Coder: TCL/C/php

Hors ligne

#30 09/10/2012 20:03:53

mat7
Nouveau IRCzien
Lieu : Angers
Inscription : 11/11/2011
Messages : 14

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

Salut,

disons que j'ai toujours pratiqué Unrealircd depuis quelques années, il faut bien se diversifier smile
j'utilise du tcl, en C faut pas trop m'en demander :s

Parcontre le soucis du ircu sur mon installation la, c'est qu'il tiens connecter que 15secondes a peu pres. aurais-je oublié quelque chose ?

Merci.

Hors ligne

#31 09/10/2012 20:16:50

Artefact
IRCzien
Lieu : Paris
Inscription : 06/09/2011
Messages : 140

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

J'espère pour toi que ton dédié est pas un 64 bits ?
(de mémoire, certains IRCD sont pas compatibles sur une machine qui tourne sur 64 bits).

Hors ligne

#32 09/10/2012 21:13:47

Ste
Nouveau IRCzien
Lieu : Germany
Inscription : 09/10/2012
Messages : 15
Site Web

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

Exact Artefact, les anciens ircu2.10.10 et inferieur on besoin d'un systeme 32 bits !


¤ Ste ¤
IRC Admin :: Olympe
Coder: TCL/C/php

Hors ligne

#33 09/10/2012 21:36:55

mat7
Nouveau IRCzien
Lieu : Angers
Inscription : 11/11/2011
Messages : 14

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

comme ça c'est réglé, roll

Merci.

Hors ligne

#34 09/10/2012 23:36:09

Ste
Nouveau IRCzien
Lieu : Germany
Inscription : 09/10/2012
Messages : 15
Site Web

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

Au pire, réinstalle ta box en 32bit si possible


¤ Ste ¤
IRC Admin :: Olympe
Coder: TCL/C/php

Hors ligne

#35 10/10/2012 12:01:54

Artefact
IRCzien
Lieu : Paris
Inscription : 06/09/2011
Messages : 140

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

C'est bien ce qu'il me semblait smile
Si tu as pas la possibilité de faire ton dédié en 32 bits, je peux héberger ton IRCD sur mon dédié (Gratuitement).

Hors ligne

#36 10/10/2012 15:13:57

Ste
Nouveau IRCzien
Lieu : Germany
Inscription : 09/10/2012
Messages : 15
Site Web

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

de même  yikes)


¤ Ste ¤
IRC Admin :: Olympe
Coder: TCL/C/php

Hors ligne

#37 10/10/2012 21:18:22

mat7
Nouveau IRCzien
Lieu : Angers
Inscription : 11/11/2011
Messages : 14

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

je vais redémarrer mon vieux serveur en local, dommage :s

Merci de vos renseignements smile

Merci.

Hors ligne

#38 16/10/2012 17:26:43

AcidBurn
Nouveau IRCzien
Inscription : 09/01/2012
Messages : 11

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

J'ai suivis ce fil de discutions mais je me retrouve avec le soucis identique :

animaka@acidhosting:~/Exchange$ make config
make[1]: entrant dans le répertoire « /home/animaka/Exchange/config »
set: 125: Illegal option -h
make[1]: *** [config] Erreur 1
make[1]: quittant le répertoire « /home/animaka/Exchange/config »
make: *** [config] Erreur 2

Je ne pige pas...

Puis je avoir votre aide s'il vous plait?

Hors ligne

#39 16/10/2012 18:10:44

Harakiri
Administrateur
Lieu : Paris
Inscription : 02/07/2011
Messages : 260

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

Ce n'est pas le même problème.

Lorsqu'un problème est détecté par make, il est affiché par make. En gros, make[1] *** [rule] error ça ne traduit pas toujours la même erreur. Ça veut juste dire qu'il y a une erreur.
En regardant, il y a des vrais messages d'erreurs plus précis, comme ici :

set: 125: Illegal option -h

La ligne 125 est très probablement celle du fichier 'Configure', (non je ne l'ai pas deviné, j'ai juste jeté un œil aux appels à la commande set).

Code:
123 if test $unet_cv_sys_set_h = yes; then
124         set -h
125 fi

A priori il y a une incompatibilité de la commande set avec ton système ou ton environnement (l'option -h ne semble pas être supportée).
Peut être que c'est ton shell qui l'interprète en tant que builtin (commande interne) à la place de la commande du système... C'est un peu étrange, je n'ai pas ce problème.
Essaie de voir si tout fonctionne bien en retirant cet appel à set.

Mais plus globalement, le problème avec ces versions, c'est qu'elles ne sont plus maintenues. Elles sont donc censées fonctionner sur des machines avec des systèmes plus anciens.
Il y a assez logiquement des problèmes de compatibilité, puisque bien entendu, les outils et les systèmes évoluent (shell, compilateurs...).
En gros, quand on choisit un programme ancien, on choisit aussi d'avoir potentiellement des comportements étranges dans ce genre.
Dans ce cas, c'est plutôt facile à fixer puisque le code source est compilable avec 2-3 fix, mais parfois, il vaut mieux passer à autre chose si on ne sait pas exactement ce que l'on fait.

Si ton problème persiste, donne plus de détail quant au système ou au shell que tu utilises et leurs versions respectives, ça peut toujours aider.


EOF

Hors ligne

#40 17/10/2012 11:44:53

AcidBurn
Nouveau IRCzien
Inscription : 09/01/2012
Messages : 11

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

Ben à première vu en supprimant les 3 lignes décrites par Harakiri tout à l'air de bien ce passer... Le make config fonctionne par contre erreur au niveau de make...

dbuf.c: In function âdbuf_allocâ:
dbuf.c:60: error: expected â)â before âCVSâ
make[1]: *** [dbuf.o] Erreur 1

Hors ligne

#41 17/10/2012 21:03:26

Ste
Nouveau IRCzien
Lieu : Germany
Inscription : 09/10/2012
Messages : 15
Site Web

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

Hm déjà les signes exotiques de l'affichage je n'aime pas trop, ensuite et tu sur d'etre sur un systeme 32bits ?


¤ Ste ¤
IRC Admin :: Olympe
Coder: TCL/C/php

Hors ligne

#42 17/10/2012 21:19:18

Harakiri
Administrateur
Lieu : Paris
Inscription : 02/07/2011
Messages : 260

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

C'est fixé. Le fichier config.h avait été un peu rempli par n'importe quoi. Soit par la faute du shell qui a interprété un signe '*' (initialement pour une multiplication dans un #define) alors qu'il n'aurait pas du. Soit par la faute de la personne qui a rempli la configuration lors du make config.
Le code compile.


EOF

Hors ligne

#43 17/10/2012 22:35:20

Ste
Nouveau IRCzien
Lieu : Germany
Inscription : 09/10/2012
Messages : 15
Site Web

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

Ok bonne continuation alors smile


¤ Ste ¤
IRC Admin :: Olympe
Coder: TCL/C/php

Hors ligne

#44 18/10/2012 12:07:54

AcidBurn
Nouveau IRCzien
Inscription : 09/01/2012
Messages : 11

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

Par contre je ne peux ma connecter a mon serveur....

[11:19:26] * Connect retry #5 88.191.143.114 (6667)
* Identd request from 88.191.143.114
* Identd replied: 50700, 6667 : USERID : UNIX : AcidBurn
[11:19:26] * Disconnected

Voilà il y a juste sa qui s'affiche....

Hors ligne

#45 18/10/2012 14:50:34

Ste
Nouveau IRCzien
Lieu : Germany
Inscription : 09/10/2012
Messages : 15
Site Web

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

Se serai sympa d'obtenir le ircd.log !


¤ Ste ¤
IRC Admin :: Olympe
Coder: TCL/C/php

Hors ligne

#46 18/10/2012 15:42:11

AcidBurn
Nouveau IRCzien
Inscription : 09/01/2012
Messages : 11

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

Désolé Ste il n'y en a pas...

Hors ligne

#47 18/10/2012 15:43:49

Ste
Nouveau IRCzien
Lieu : Germany
Inscription : 09/10/2012
Messages : 15
Site Web

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

et en activant le .bin en -t -x 09 ?


¤ Ste ¤
IRC Admin :: Olympe
Coder: TCL/C/php

Hors ligne

#48 18/10/2012 15:49:49

AcidBurn
Nouveau IRCzien
Inscription : 09/01/2012
Messages : 11

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

je n'ai pas compris désolé...

Hors ligne

#49 18/10/2012 15:53:39

AcidBurn
Nouveau IRCzien
Inscription : 09/01/2012
Messages : 11

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

./ircd: DEBUGMODE must be defined for -x y

Hors ligne

#50 18/10/2012 17:05:55

Ste
Nouveau IRCzien
Lieu : Germany
Inscription : 09/10/2012
Messages : 15
Site Web

Re : quelle version d'IRCU je peux user pour faire fonctionner à un CServic

./ircd -t -x 9


¤ Ste ¤
IRC Admin :: Olympe
Coder: TCL/C/php

Hors ligne

Pied de page des forums

481555 visites ( 222 aujourd'hui ) 7 visiteurs en ligne
Copyright © 2004 - 2013 IRCz